Freebird Games Community

Episode 1: To the Moon => To the Moon - Technical => Topic started by: ritwik_mishra on December 15, 2015, 02:19:11 AM

Title: Game won't open
Post by: ritwik_mishra on December 15, 2015, 02:19:11 AM
I installed To the moon without any hassles. Bonus game opened up easily but "To The Moon.exe" or shortcut never opened. It just opens up and closes in the background. I Added the game to DEP exceptions. Then even the bonus game stopped working. It shows the message "RGSS player stopped working" and closes, meanwhile To The Moon.exe still doesn't open. I tried this post

Quote
If "RGSS has stopped working" thing happens, please try copying these two files into the TtM folder:

1. (overwrite existing file) https://dl.dropboxusercontent.com/u/55619539/To%20the%20Moon.ini (https://dl.dropboxusercontent.com/u/55619539/To%20the%20Moon.ini)
2. https://dl.dropboxusercontent.com/u/55619539/RGSS104E.dll (https://dl.dropboxusercontent.com/u/55619539/RGSS104E.dll)

There might've been another DEP thing that's overriding the base exception, but that should get around the issue altogether.


But no success, reinstalled it several times, what to do now?

EDIT: http://freebirdgames.com/forum/index.php?topic=6174.0 (http://freebirdgames.com/forum/index.php?topic=6174.0) Read this thread, still no success -_-

EDIT 2: I replaced the dll files of the bonus game with the dll mentioned above, bonus game started!! But problem is still the same with To the Moon :(
Title: Re: Game won't open
Post by: Legacyblade on December 15, 2015, 12:56:16 PM
Did you replace the ini as well? Notice how the quote you posted links to both an ini and dll file. Past that, I think ya may be ou of luck on that machine. I've never actually encountered this error myself.
Title: Re: Game won't open
Post by: ritwik_mishra on December 15, 2015, 04:12:29 PM
Yeah replaced ini file and pasted the 104.dll
Even without replacing ini file, copied 104.dll, renamed older as .BACK and renamed this one 102.dll.
Still no success.

PS: Never experienced this much problems in high-end, high-spec games. Now even I am thinking maybe the machine is jinxed :(
Title: Re: Game won't open
Post by: Eli on December 18, 2015, 11:03:06 AM
Please try this, rename "To the Moon.exe" to something else, then copy the "Sig​Corp Minisode 2​.​exe" to your main game's folder and rename it to "To the Moon.exe" and try to run the game.
If it still didn't work, also make sure you have RGSS104E.dll in there.

(I'm assuming by bonus game you mean the minisodes).
Title: Re: Game won't open
Post by: ritwik_mishra on December 19, 2015, 06:41:39 AM
Bonus game (SigCorp - Holiday Special) opened up and this error is displayed (https://freebirdgames.com/forum/proxy.php?request=http%3A%2F%2Fi66.tinypic.com%2F34h88x0.png&hash=c4fbcb61881a3765ca4efa3864471f04)
Title: Re: Game won't open
Post by: Eli on December 19, 2015, 04:20:53 PM
Well, I'm a little confused, I'm not sure how this happened, but my only guess is that you have copied and renamed the "Siggy - Holiday Special.rgssad" to "To the Moon.rgssad" instead of the exe files and that's why this is happening.

If I remember correctly, Windows hides file extensions by default, so make sure you copy and rename the correct file, and if necessary, modify your Folder Options to show extensions too.

I would suggest uninstalling and reinstalling the game before trying this as there might be some other issues with your installation too.

Edit: If you have got the game from Steam, even changing the exe files might not work.
Title: Re: Game won't open
Post by: ritwik_mishra on December 21, 2015, 01:23:55 AM
Problem solved:
The antivirus was blocking the steam_app.dll file -_- disabled it, reinstalled and added the dll to the exception. Done! Thanks for the help ^_^
 :hug:
Title: Re: Game won't open
Post by: Eli on December 21, 2015, 02:46:23 AM
I'm glad that it is fixed now, and thanks for sharing the solution :)
Title: Re: Game won't open
Post by: Katharine on April 02, 2018, 04:55:06 AM
I try to turn off the antivirus as you suggested. And use it normally.