Freebird Games Community

Episode 1: To the Moon => To the Moon - Technical => Topic started by: colbzter on January 20, 2013, 05:31:45 PM

Title: Extremely low framerate.
Post by: colbzter on January 20, 2013, 05:31:45 PM
Hey guys, I hate to make this my first post, but I would really like to have this problem addressed.

Whenever I try to play To the Moon the framerate is so bad it's painful to play. When dialogue is happening it appears roughly 1 word at a time instead of the smooth, 1 letter at a time.

I have a 3 core processor, 4 gigs of ram, and a powerful graphics card. (I have windows 7 64x, if that's relevant) I can run Crysis 2 at 5 times the framerate To the Moon is getting.

I tried playing To the Moon on my mother's computer and it runs great, very high FPS, but that's on a low-end
laptop.  (she also has windows 7.)

The problem is, I rarely have the opportunity to use her computer, so I would love to be able to play on mine.

I tried all the different settings from the F1 menu. Please help in any way you can


P.S. I also can't get FRAPS to recognize it as a game at all, so I can't record. I think that may be a problem with RPG maker though.
Title: Re: Extremely low framerate.
Post by: Just Lance on January 20, 2013, 06:05:59 PM
Is the game setting deafult? Like process priority.
Do you run any other applications on background?
Does the low end laptop run 32-bit Win 7 by any chance?
Did you tried switching between full screen and windowed mode?
What is your CPU exactly and how much is it used while playing the game?
Have you tried Win XP compatibility mode + run as admin?
Do you have latest drivers?

That's all I can think of now... Sorry for the question spree. It might have something to do with .dll but I don't really know much about that stuff.
Title: Re: Extremely low framerate.
Post by: Reives on January 20, 2013, 06:18:46 PM
From what I remember, this is more of a hardware incompatibility issue -- I can't recall if it was the graphics card or something else, but it's happened to someone else too. See if windowed mode solves the issue -- Alt+Enter should toggle to it. If that works, then magnifier (start key + '+' key) works nicely with it. Sorry for the inconvenience!
Title: Re: Extremely low framerate.
Post by: colbzter on January 20, 2013, 08:30:41 PM
Is the game setting deafult? Like process priority.
Do you run any other applications on background?
Does the low end laptop run 32-bit Win 7 by any chance?
Did you tried switching between full screen and windowed mode?
What is your CPU exactly and how much is it used while playing the game?
Have you tried Win XP compatibility mode + run as admin?
Do you have latest drivers?

That's all I can think of now... Sorry for the question spree. It might have something to do with .dll but I don't really know much about that stuff.


From what I remember, this is more of a hardware incompatibility issue -- I can't recall if it was the graphics card or something else, but it's happened to someone else too. See if windowed mode solves the issue -- Alt+Enter should toggle to it. If that works, then magnifier (start key + '+' key) works nicely with it. Sorry for the inconvenience!


Thanks a lot for the quick responses.

Process priority was normal, but now I have tried above normal, high, and realtime. It now only lags during dialogue. (Very similar to Marty123's problem http://freebirdgames.com/forum/index.php?topic=4646.0 (http://freebirdgames.com/forum/index.php?topic=4646.0)) The rest of the game runs smoothly, but it is still very annoying.
No programs running in backround.
The laptop is also 64x.
Processor   AMD Phenom(tm) 8400 Triple-Core Processor, 2100 Mhz, 3 Core(s), 3 Logical Processor(s). CPU usage is between 5-15% while running it.  ???
Tried XP compatibility mode just now, no difference.
All drivers are updated.

Also, I tried running in windowed and I see no difference from full screen as far as framerate goes.


So it is much more playable now. Thanks for the help.

P.S. Before, my solution was to use Cheat Engine's 'speed hack' to force the framerate up, this worked for dialogue, but the problem is the character's would run 100 Kilometers an hour, making them hard to control.
Title: Re: Extremely low framerate.
Post by: Zeriab on January 24, 2013, 03:01:06 PM
If you don't mind, can I get you to disable Aero?
I would very much like to know if that has any impact :)
Title: Re: Extremely low framerate.
Post by: colbzter on January 24, 2013, 04:39:32 PM
If you don't mind, can I get you to disable Aero?
I would very much like to know if that has any impact :)

I just disabled Aero. Sadly no, it made no visible difference.  :'(